Ford Automobiles Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello this is my first post and I’m sure it has been covered before but looking for some help,

I have a 2006 mk3 mondeo st 2.2tdci, recently the speedo has started to play up it could go for 10 miles or less then drops to zero, it has got steadily worse and now it doesn’t work attal, as soon as you start the car the dashes appear that replace where the mileage is supposed to be, and Speedo doesn’t move.

work that I have already done is,
Change the battery
New wheel speed sensor
New wheel bearing
Cleaned earths from battery

also when the speedo isn’t working the car runs rough and has lack of power, but if the speedo decides to start working the car runs perfectly, I am also hoping to plug the computer into the car at the weekend to see what codes it shows up, has anyone had this same problem? And could maybe point me in the right direction

a lovely car to drive when it’s going right so keen to get this sorted. Any help would be much appreciated.

Mark
 

· Little Megger
Joined
·
4,941 Posts
Wait and see what codes you get. Why did you replace the wheel sensors? Did the speedo give trouble AFTER thec wheel bearing was replaced?
 

· Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Thanks for the reply, the wheel bearing was so when I changed it I did the speed sensor at the same time so I could rule them both out, all was well for a few weeks then the problem returned.

cheers
Mark
 

· Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Sorry, last post didn’t make sense,

Thanks for the reply, the wheel bearing (Driver side) was bad so when I changed it I did the speed sensor at the same time so I could rule them both out, before that the fault was intermittent, after I changed both bearing and sensor all was well for a few weeks then the problem returned.

cheers
Mark
 

· Little Megger
Joined
·
4,941 Posts
Hmm... Wait to see if you get any codes...don't use a generic code reader tho' - you won't see any Ford-specific codes with those.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Update!

got my brother in law to plug his code reader into the mondeo tonight.

So took the mondeo to my workshop got both front brake calipers replaced as the old ones were binding slightly all is well with brakes now 😁

also on the way to the workshop (about 4 miles) car ran perfectly and speedo worked, no dashes where the mileage should be, Typical!! So after stopping and starting the car a few times the fault appears again so we plugged it into the reader to look for faults I don’t know a lot about them but this is what it picked up

P0500 vehical speed sensor A
C13D0 unknown fault code
P3900 unknown fault code

We cleared the faults and they didn’t come back car then drove home perfectly again speedo working no dashes, no lack of power, But for how long it will last is a guessing game.

I know it’s not a ford specific reader but hopefully these might be a bit of a help before I throw more money at it taking it to a garage

any ideas?
cheers
 

· Super Moderator
Joined
·
31,912 Posts
Hopefully a reader that uses Forscan will give better results approx £20 or less if your willing to try and return them if they
dont work as intended. I went through a few seemingly identical ones before giving up and getting the tunnelrat ones.

Externally they use the same labels but they dont all use the same chips inside, it may work to read basic codes but
may fail when it needs to read data on the higher speed circuits.

P3900 could mean anything from the clutch pack on gears 6 and 8 out of spec, shift solenoid performance, your fuel pressure
is incorrect, faulty injector cylinder 6 knock sensor out of range, related to a non start issue on a petrol engine.

Obviously most of those codes do not apply to your car.
 
1 - 7 of 7 Posts
Top