Ford Automobiles Forum banner
1 - 20 of 26 Posts

·
Little Megger
Joined
·
68 Posts
Discussion Starter · #1 ·
I recently bought 2007 Mondeo, everything worked fine. Then today the controls on the right hand side of the steering wheel with OK in the middle and the left, right up down buttons isnt working.

The ok button is working fine, i could go up and down this morning but not left or right, and now only ok works.

I really dont know what this is as the buttons seem to be in good physical condition.

Its really annoying because i cant access any of the options using the controls moving up and down stations

I do have a 3 month warrenty but would like to see if it is something easy to fix to avoide having to take it in

Any help would be greatly appreciated
 

·
Megger
Joined
·
262 Posts
It's probably a software glitch. I have known the cruise control buttons to stop working also.
Everything is usually fine in the morning... maybe it was just a bad dream.
 

·
Little Megger
Joined
·
68 Posts
Discussion Starter · #3 ·
It's probably a software glitch. I have known the cruise control buttons to stop working also.
Everything is usually fine in the morning... maybe it was just a bad dream.
Well i got up this morning tested the controls again and they still dont work, looks like its not a clitch and may require attention
 

·
Super Moderator
Joined
·
19,004 Posts
take it back mate, thats what the warranty is for.
 

·
Little Megger
Joined
·
68 Posts
Discussion Starter · #5 ·
Gonna go in on monday and get it sorted
 

·
Little Megger
Joined
·
68 Posts
Discussion Starter · #6 ·
Got it sorted, Ford had it two days as after they found out what it was had to order the part. Was told they needed a switch. Anyway all sorted
 

·
Little Megger
Joined
·
68 Posts
Discussion Starter · #7 ·
Got it sorted, Ford had it two days as after they found out what it was had to order the part. Was told they needed a switch. Anyway all sorted
Got the same problem again - i used bluetooth to make a call today then afterwards the up down buttons stopped working, this is the same as before and teh replaced a 'D pad' and then it was fine

Very frustrating as only had teh car 4 weeks and this is the 2nd time going back to the garage, dunno if its related to bluetooth/ phone or not

Any ideas or similar problems

cheers
 

·
Super Moderator
Joined
·
19,004 Posts
Got it sorted, Ford had it two days as after they found out what it was had to order the part. Was told they needed a switch. Anyway all sorted
Got the same problem again - i used bluetooth to make a call today then afterwards the up down buttons stopped working, this is the same as before and teh replaced a 'D pad' and then it was fine

Very frustrating as only had teh car 4 weeks and this is the 2nd time going back to the garage, dunno if its related to bluetooth/ phone or not

Any ideas or similar problems

cheers
[/quote]

If you got it from ford and have only had it 4 weeks i'd consider suggesting you're considering to 'reject' the car and get your money back (it is your right to do this) and get one from another dealership, (poxhall?) as you're not happy with it.
I'm not suggesting you buy a poxhall, but maybe the prospect of you rejecting the car may give the dealer a bit more incentive to sort it out once and for all...

http://www.direct.gov.uk/en/Governmentcitizensandrights/Consumerrights/Buyingacar-yourconsumerrights/DG_183047
 

·
Little Megger
Joined
·
68 Posts
Discussion Starter · #9 ·
Im hoping it wont have to go that far as i really like the car but its just this issue that is very frustrating

Fingers crossed that it will be sorted this time but i will be checking it all out before i leave the garage
 

·
Megger
Joined
·
262 Posts
Could be a problem with the clockspring or steering wheel control module.
Have you used any liquid cleaners on the buttons?
 

·
Little Megger
Joined
·
68 Posts
Discussion Starter · #11 ·
Ive not used anything on the steering wheel its really strange of it just happens
 

·
Little Megger
Joined
·
68 Posts
Discussion Starter · #12 ·
Had the car back into garage on wednesday, they had it all day and still dont know whats causing the problem. They want the master technician to have a look at it and guess what he is on holiday. So i have to take it in again on monday and leave it for a couple of days so they can have a look at it.

I just wanna get it sorted sick of going back and forth
 

·
Registered
Joined
·
6 Posts
Hi Chris, did you ever get this problem sorted? Did they find out what was at fault?

The reason I ask, not unsurprisingly, is mine started doing the same thing. Worked fine one day, then only Left, Right and OK. Today it all works bar Up, which isn't so bad as you can use Down to keep scrolling through the list. Seems to change every day!?

Any info would be much appreciated.

Cheers
 

·
Dirty old Megger
Joined
·
1,417 Posts
chris1980 hasn't been active since june last year.

However, if your car isn't in warranty, there are a couple of remedies that can be tried:

1) Undo the airbag and the right-hand button module from the steering wheel, disconnect the button module,

and give it a good dousing with contact cleaner spray (can be bought at the likes of RS Components and Maplin).

2) Write down the radio code, disconnect the battery, and leave it off for about 5 minutes or so.

Reconnect, and test again. If OK, enter the code into the radio, re-initialise the one-touch feature of the electric windows, and rock on.
 

·
Registered
Joined
·
6 Posts
Cheers Costeau,

Think I might try option 2 first as the thought of fiddling round with the airbag does fill me with some apprehension.

I'll report back with my results when i get the chance to give it a go

Thanks again.
 

·
Dirty old Megger
Joined
·
1,417 Posts
No worries. There's a thread on here somewhere regarding the cruise control buttons, and one user who went down the DIY route on fixing them. This included some info on handling the air bag.

Usually, I'd leave the car without power for half an hour before working on the air bags,

giving the system some time to discharge. Also, I recommend placing the air bag face (the side you see when you're driving) up on a bench once it's disconnected.

The level of difficulty shouldn't be much different with the other steering buttons.

In fact, if you don't have cruise control, it should actually be slightly less complicated once you have the button modules out.
 

·
Registered
Joined
·
1 Posts
I know the thread's pretty old - but frustratingly this has just happened to my Mondeo :( Only the up & down functions stopped working - so I can't reset the trip meter & stuff like that. Might just try to battery disconnect option & see what happens.
 

·
Little Megger
Joined
·
161 Posts
I know the thread's pretty old - but frustratingly this has just happened to my Mondeo :( Only the up & down functions stopped working - so I can't reset the trip meter & stuff like that. Might just try to battery disconnect option & see what happens.
Me too! lol

Once the cabin has warmed up I lose all functionality of the left-hand set of controls (stereo). If any key-presses do register, the stereo volume decreases, regardless of which button was pressed. Very odd!

Let me know how disconnecting the battery goes!

JB
 

·
Registered
Joined
·
292 Posts
Holy thread revival batman and all that other stuff ????????

Anyone know what's causing it? Mine does it, it's intermittent, I can hold onto one of the directional buttons and sometimes it will unfreeze, I can't recall if I've had the battery off but it's still doing it, all the threads are left unsolved after searching.

I just wanted to see if anyone has cured it, save me going through the motions figuring out what it is as it seems it has been brought up a few times.

Thanks.
 

·
Registered
Joined
·
292 Posts
So, just an interim update, I disconnected the battery and straight afterwards the controls seemed to freeze again ????????‍♂

I then used Forscan and ran a function test on the body module, I went out earlier for a drive and it seemed to have not frozen, but I didn't check it towards the end of the trip, as I usually notice it after a while of driving and not straight away.

I think my next course of action if it happens again will be to take the controls off and clean the contacts on the buttons and make sure they are functioning correctly and not holding a button down.

I couldn't find steering wheel controls on Forscan to see if the body module is seeing the button presses which was annoying, but hey ho, it is what it is ????
 
1 - 20 of 26 Posts
Top