Ford Automobiles Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter · #1 ·
hi lads im doing a (p reg)2L mondeo up to sell and iv got a small problem with it on tick over it misses a bit not a lot but just a bit and some times when you rev it up it comes back down to tick over and then starts to hunt up and down a qwick blip on the throtel and i have a tick over again with its very small miss ...iv heard people talk about the idle valve if this is the proplem where is it thanks :blush:
 

·
Registered
Joined
·
219 Posts
Its either the idle valve or the EGR valve/ something along the lines of the EGR, my friend has a mk2, his was the same, we replaced the EGR valve, didnt solve it, EGR Sensor, didnt solve it, the pipe leading the the EGR Valve, that solved it... so it could be that or the idle valve.
 

·
MEG Corporal
Joined
·
866 Posts
As its a silvertop, it would be worth checking the rubber T piece under the coilpack first.
 

·
MEG Corporal
Joined
·
866 Posts
If its P reg then its a silvertop and it will have a T piece under the coilpack.... unless someone has dropped a blacktop in there :whistling:
 

·
Registered
Joined
·
180 Posts
Discussion Starter · #7 ·
thanks lads for tips you gave me i have now sorted it out it was the EGR SOLENOID that was no good i did a lot of looking into it on here and got the answers . plus my car does not have a T in the pipe line its plumbed diferent .all the MK1 i have seen this week are as you say but this is a P reg MK2 2L silver top wich dose not have a t piece as the pipe from the front of the motor which is a breather that goes straght to the inlet manifold .. :thankyousign:
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top