Ford Automobiles Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter · #1 ·
As of this afternoon, the wiper relay (I guess) has started to make a ticking noise when you switch between the intermittent, normal and fast wipe stalk positions.

Worst of all, it ticks each time it does an intermittent sweep including when it starts the wipe process when you spray the washers and then when it does the secondary sweep a few secs later :mad: Thought I'd got away from ticking relays when I binned my 307!

I swear it has not been doing this up until now!!!!

Any suggestions? Is the relay on it's way out?
 

·
MEG Captain
Joined
·
4,819 Posts
sounds like it is on its way out , cant say much more to be honest :sad:
 

·
MEG Captain
Joined
·
4,819 Posts
dont know , hang on , i will have a look at mine :thumbup:

edit --- sorry , i thought the manual showed what was what , it doesnt :shifty: , anyway , pull the glovebox out and set the wipers away , if it is as bad as you say then you should be able to identify easily :L
 

·
It was 49.95
Joined
·
10,123 Posts
mine ticks between intermittent wipes,

its a mk2, and not very loud, and yes i get a tick on flicking from constant, single etc
 

·
Big Megger
Joined
·
372 Posts
not being funny but have you cleared out your glovebox lately? Don't know about you but mine frequently gets filled up with junk, car park tickets, cd's, sweetie wrappers etc!

Maybe having less in your glovebox lets the sound out more?!? :question:
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top