Ford Automobiles Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 ·
hi :laugh:
this is my first post so be kind!
i need help with my sat nav which came with the car. its the touch screen mono zone version. when you go into sat nav mode it just has no sense of direction..i mean if you head of north it goes east etc..i did the diagnostic check using the number i found in the workshop section and it is picking a signal up ok..but on the screen it shows the gps icon which according to the manual means there is no signal?!? next question: i bought a new ford denso 2004-2005 sat nav disc..where does this go?? i put it in the cd slot on the front of the sat nav unit and it comes up disc error and spits it out..am i doing something wrong?
HELP PLEASE!!!!!!!!
 

·
MEG Captain
Joined
·
4,819 Posts
first point , are you stopped when first switching the satnav on , this i expect will allow the unit to lock onto satellites properly , second point , the disc goes in the boot dvd unit , not sure where it is though , i only remeber that from other threads :L
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #3 ·
yes i am stationary when i press the sat nav button..but i cant find where the disc goes..i have looked everywhere! the book that came with the car says nowt. should of said my car is a '03 ghia model..even went to a ford dealer yesterday and they didnt know either..that gave me confidence! anyone else got any ideas?
 

·
MEG Captain
Joined
·
4,819 Posts
the unit is in the boot to put the disc in , have you had a good look !!!!!!!!!!!
 

·
IDS SERVICES AVAILABLE - DENSO SPECIALIST
Joined
·
3,444 Posts
The Touchscreen sat nav unit is behind the boot trim on the LH side of the boot. You should have a console there for the 6 disc changer, this trim need to be removed , once you have done that you will see the dvd drive mounted vertically on the NS rear inner panel. Weird, i know, but that the design.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #6 ·
cheers guys i found it behind the trim..stupid place to put it!
well anyway its updated the map but the thing still doesnt work..it still shows 'getting no signal' on the screen..oh well its off to Ford i go to see if they can find the problem..till then i will use my tom tom..(which could be for sale soon ;) )
cheers for all the help
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #9 ·
ok i will check that today..is the ariel in the roof lining at the front under the controls for the sunroof?? ho do you get that cover off to have a look cos it loos like it has for retainers inside and i cant see screws anywhere?
 

·
IDS SERVICES AVAILABLE - DENSO SPECIALIST
Joined
·
3,444 Posts
best thing to do is just take it all out and give it to me... That way any problems you might have disappear... ho ho ho
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top