Ford Automobiles Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I have a Mondeo MK2 1999 and when I switched on the engine this morning, the brake light, the ABS light and the traction control light all lit up and remained lit.

The local garage checked it out and have told me that the brakes are fine and it must be eletrical.

Before I call an auto electrician out, is there anything simple I can check.

Thanks

Stuart
 

·
TDDI Buff
Joined
·
37,060 Posts
i would check earth points specially in the engine bay as theyre more likely to get rusty theres some around the battery tray dunno where they all are.
 

·
MEG Commander
Joined
·
6,006 Posts
Sounds like a faulty ABS sensor, this would bring the warning lights on that you have.

Steve
 

·
MEG Corporal
Joined
·
802 Posts
I had similar, but with a few more problems too !!
The ABS and traction control lights came on and stayed on, a loud whining noise started (it had been making the noise for a few weeks but very quiet) but went quiet again when the radio/lights where switched off, got home and stopped the engine, then it wouldnt start again.
I have just changed the alternator over the weekend and so far none of the problems have started again, so I assume the alternator wasnt charging the battery properly till eventually there was minimal charge left and it wouldnt start.
 

·
MEG Captain
Joined
·
4,819 Posts
did the car start as normal or not ????? :L
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top