Ford Automobiles Forum banner
1 - 7 of 7 Posts

·
MEG general
Joined
·
1,507 Posts
Discussion Starter · #1 ·
would you guys and be able to help does anybody know the location of the oilpressure switch and the location of the water temp switch on a mk1 2.0 si as i need to change mine as the oil light has stopped working and the temp gauge works when it feels like it
 

·
Turbo Boost Me!
Joined
·
1,018 Posts
Oil pressure switch is on the bacl of the block and the temp sender is on the bottom left of the thermostat housing
 

·
MEG general
Joined
·
1,507 Posts
Discussion Starter · #3 ·
is the temp switch the one on the bottom of the thermostat housing not the one on the top?
 

·
Turbo Boost Me!
Joined
·
1,018 Posts
Avinitlarge said:
the temp sender is on the bottom left of the thermostat housing
 

·
MEG general
Joined
·
1,507 Posts
Discussion Starter · #5 ·
cheers my man i will do it in the morning. sorry for sounding thick its been one of those days. and my brain hurts
 

·
irishghiax
Joined
·
798 Posts
oil pressure switch location :L
 

Attachments

·
Big Megger
Joined
·
372 Posts
sholudn't you be investigating why these don't work, rather than just fitting different gauges? Does the oil light come on when you switch on the ignition? If not, remove the wire off the oil switch, earth it, then turn on the ignition and see if it comes on. If it does, the switch is knackered, (unlikely) and if it doesn't come on, then it'll be the bulb.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top